Create A Static Visualization

How to create a Static Visualization

On Dragon1, creating a visualization is easy. It involves a few basic steps. And once you know these steps you can really control anything you want to do.

Here we are going to create a static visualization using a template. A static visualization is a visualization without underlying data, models or views.

This visualization will still be possible interactive (clickable) if you provide information on title, description and images for the entityclasses/shapes that are on the visualization.

To create a static visualization:

  • Login to Dragon1 via www.dragon1.com/login
  • Click on Visual Designer in the menu on the left
  • Open an existing cabinet via File --> Open From --> Cabinet
  • Alternatively create a cabinet here via the menuitem Insert --> Insert Cabinet, and next insert a dossier in the cabinet and next insert a folder in the dossier likewise.
  • In the cabinet there are dossiers and folders. Now expand a dossier (by clicking on the plus) and select a folder (by clicking on the name).
  • Next insert a visualization via the menu item Insert --> Insert Visualization.
  • Next provide a name for the visualization in the dialog and click on the button 'Insert Visualization'.
  • Next selected that visualization item in the treeview.
  • Next choose a template via File --> New…
  • Select a template in the dialog by clicking on the picture.
  • Now you see a visualization instantiated on the visualization canvas.
  • Next Click on save.

Create a Static Visualization using Shapes

You can follow the steps above, but instead of using a template, you can also use a large number of shapes grouped into a library to draw a visualization.

First make sure you have selected a visualization item in the treeview. Next, go to the left bottom of the Visual Designer application and expand the icon libraries you see (just by clicking on their name).

You can also choose to open up other libraries by clicking More Shapes...

The first icon library you see has the name of your account is often first empty. Here you can add your own user-defined icons.

Create a Static Visualization via the Templates page

All these steps above can also be done in 1 click.

If you login to Dragon1 and then go to the template page www.dragon1.com/workplace/templates, you only have to click on a template to have it being instantiated, put into a cabinet and shown to you in the visual designer.

Screenshots on How To Create A Static Visualization

Here follow the screenshots of every step on how to create a static visualization.

Hotkeys or special clicks were done, it is mentioned at the screenshot.

  • Click on Visual Designer in the menu on the left:
    click on visual designer left menu

  • Open an existing cabinet via File --> Open From --> Cabinet:
    open existing cabinet via file

  • Select a cabinet in the dialog:
    select cabinet in dialog

  • In the cabinet there are dossiers and folders. Now expand a dossier (by clicking on the plus) and select a folder (by clicking on the name). (below you see we have actually selected a visualization item to check if the visualization canvas has content. If you select a folder, you will always see an empty canvas).
    NOTE: If you want to enlarge the treeview, you can click on the word "Explorer" once and twice:
    expand dossier select folder

  • Next, insert a visualization via the menu item Insert --> Insert Visualization:
    insert visualization via menu item insert

  • Next, provide a name for the visualization in the dialog and click on the button 'Insert Visualization':
    provide name visualization in dialog

  • Next, select that visualization item in the treeview:
    select visualization item in treeview

  • Next, choose a template via File --> New...:
    choose template via file

  • Select a template in the dialog by clicking on that template:
    select template in dialog

  • You see a visualization instantiated on the visualization canvas:
    visualization instantiated on visualization canvas

  • Use the zoom controls to fit the visualization page. Know that you can pan the visualization by using your right mouse down button and drag the mouse:
    zoom controls to fit visualization page

  • Drag shapes from the icon libraries at the left bottom. Optionally switch on more icon libraries by clicking on More Shapes...:
    drag shapes from icon libraries at the left bottom

    switch on more icon libraries by clicking on more shapes

  • Next, click on the orange button Save, so your visualization is saved for viewing it a next time:
    click on orange button save, visualization is saved for viewing next time